summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ce7b3214..d3d973813 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,6 +253,16 @@ fi
AC_SUBST(GST_INTERFACES_LIBS)
+dnl check for gstreamer-interfaces; uinstalled is selected preferentially
+PKG_CHECK_MODULES(GST_PLUGINS_LIBS, gstreamer-libs-$GST_MAJORMINOR >= $GST_REQ,
+ HAVE_GST_PLUGINS="yes", HAVE_GST_PLUGINS="no")
+
+if test "x$HAVE_GST_PLUGINS" = "xno"; then
+ AC_MSG_ERROR(no GStreamer Plugins Libs found)
+fi
+
+AC_SUBST(GST_PLUGINS_LIBS)
+
dnl Determine endianness
AC_C_BIGENDIAN