summaryrefslogtreecommitdiff
path: root/ext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 951d2d512..2c38742b2 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -82,6 +82,12 @@ else
EGLGLES_DIR=
endif
+if USE_GL
+GL_DIR=gl
+else
+GL_DIR=
+endif
+
if USE_RESINDVD
RESINDVD_DIR = resindvd
else
@@ -154,6 +160,12 @@ else
LIBMMS_DIR=
endif
+if USE_LIBVISUAL
+LIBVISUAL_DIR=libvisual
+else
+LIBVISUAL_DIR=
+endif
+
if USE_MODPLUG
MODPLUG_DIR=modplug
else
@@ -405,6 +417,7 @@ SUBDIRS=\
$(DTS_DIR) \
$(RESINDVD_DIR) \
$(EGLGLES_DIR) \
+ $(GL_DIR) \
$(FAAC_DIR) \
$(FAAD_DIR) \
$(FLITE_DIR) \
@@ -417,6 +430,7 @@ SUBDIRS=\
$(LV2_DIR) \
$(LIBFAME_DIR) \
$(LIBMMS_DIR) \
+ $(LIBVISUAL_DIR) \
$(MODPLUG_DIR) \
$(MPEG2ENC_DIR) \
$(MPG123_DIR) \
@@ -478,6 +492,7 @@ DIST_SUBDIRS = \
daala \
dts \
eglgles \
+ gl \
modplug \
mimic \
mpeg2enc \