summaryrefslogtreecommitdiff
path: root/ext/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gtk/Makefile.am')
-rw-r--r--ext/gtk/Makefile.am46
1 files changed, 0 insertions, 46 deletions
diff --git a/ext/gtk/Makefile.am b/ext/gtk/Makefile.am
deleted file mode 100644
index 057ff3f18..000000000
--- a/ext/gtk/Makefile.am
+++ /dev/null
@@ -1,46 +0,0 @@
-# preamble
-NULL =
-BUILT_SOURCES =
-CLEANFILES =
-EXTRA_DIST =
-DISTCLEANFILES =
-lib_LTLIBRARIES =
-
-# source
-sources = \
- gtkgstbasewidget.c \
- gtkgstbasewidget.h \
- gtkgstwidget.c \
- gtkgstwidget.h \
- gstgtkbasesink.c \
- gstgtkbasesink.h \
- gstgtksink.c \
- gstgtksink.h \
- gstgtkutils.c \
- gstgtkutils.h \
- gstplugin.c \
- $(NULL)
-
-libgstgtk_la_CFLAGS = \
- $(GST_PLUGINS_BAD_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS) \
- $(GST_GL_CFLAGS) \
- $(GST_CFLAGS) \
- $(GTK3_CFLAGS)
-libgstgtk_la_LIBADD = \
- $(GST_PLUGINS_BASE_LIBS) \
- -lgstvideo-$(GST_API_VERSION) \
- $(GST_BASE_LIBS) \
- $(GTK3_LIBS)
-
-libgstgtk_la_SOURCES = $(sources)
-libgstgtk_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-
-if USE_GTK3_GL
-if USE_GL
-libgstgtk_la_SOURCES += gstgtkglsink.c gstgtkglsink.h gtkgstglwidget.c gtkgstglwidget.h
-libgstgtk_la_LIBADD += $(GST_GL_LIBS)
-endif
-endif
-
-plugin_LTLIBRARIES = libgstgtk.la