summaryrefslogtreecommitdiff
path: root/ext/hls/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/hls/meson.build')
-rw-r--r--ext/hls/meson.build24
1 files changed, 13 insertions, 11 deletions
diff --git a/ext/hls/meson.build b/ext/hls/meson.build
index 081a0968a..f3ea432c0 100644
--- a/ext/hls/meson.build
+++ b/ext/hls/meson.build
@@ -25,14 +25,16 @@ else
endif
endif
-gsthls = library('gsthls',
- hls_sources,
- c_args : gst_plugins_bad_args + hls_cargs,
- link_args : noseh_link_args,
- include_directories : [configinc],
- dependencies : [gstpbutils_dep, gsttag_dep, gstvideo_dep,
- gstadaptivedemux_dep, gsturidownloader_dep,
- hls_crypto_dep],
- install : true,
- install_dir : plugins_install_dir,
-)
+if hls_crypto_dep.found()
+ gsthls = library('gsthls',
+ hls_sources,
+ c_args : gst_plugins_bad_args + hls_cargs,
+ link_args : noseh_link_args,
+ include_directories : [configinc],
+ dependencies : [gstpbutils_dep, gsttag_dep, gstvideo_dep,
+ gstadaptivedemux_dep, gsturidownloader_dep,
+ hls_crypto_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif