summaryrefslogtreecommitdiff
path: root/ext/mpg123/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/mpg123/meson.build')
-rw-r--r--ext/mpg123/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/ext/mpg123/meson.build b/ext/mpg123/meson.build
new file mode 100644
index 000000000..d4e16c9e7
--- /dev/null
+++ b/ext/mpg123/meson.build
@@ -0,0 +1,16 @@
+mpg123_sources = [
+ 'gstmpg123audiodec.c',
+]
+
+mpg123_dep = dependency('libmpg123', version : '>= 1.3', required : false)
+
+if mpg123_dep.found()
+ gstmpg123 = library('gstmpg123',
+ mpg123_sources,
+ c_args : gst_plugins_bad_args,
+ include_directories : [configinc],
+ dependencies : [gstaudio_dep, mpg123_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif