summaryrefslogtreecommitdiff
path: root/ext/opus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/opus/Makefile.am')
-rw-r--r--ext/opus/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/ext/opus/Makefile.am b/ext/opus/Makefile.am
index 4630715ba..c6c1a800e 100644
--- a/ext/opus/Makefile.am
+++ b/ext/opus/Makefile.am
@@ -1,20 +1,20 @@
-plugin_LTLIBRARIES = libgstopus.la
+plugin_LTLIBRARIES = libgstopusparse.la
-libgstopus_la_SOURCES = gstopus.c gstopusparse.c gstopusheader.c
-libgstopus_la_CFLAGS = \
+libgstopusparse_la_SOURCES = gstopus.c gstopusparse.c gstopusheader.c
+libgstopusparse_la_CFLAGS = \
-DGST_USE_UNSTABLE_API \
$(GST_PLUGINS_BAD_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS) \
$(GST_CFLAGS) \
$(OPUS_CFLAGS)
-libgstopus_la_LIBADD = \
+libgstopusparse_la_LIBADD = \
$(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_API_VERSION) \
-lgsttag-$(GST_API_VERSION) \
-lgstpbutils-$(GST_API_VERSION) \
$(GST_BASE_LIBS) \
$(GST_LIBS) \
$(OPUS_LIBS)
-libgstopus_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(LIBM)
-libgstopus_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
+libgstopusparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) $(LIBM)
+libgstopusparse_la_LIBTOOLFLAGS = $(GST_PLUGIN_LIBTOOLFLAGS)
noinst_HEADERS = gstopusparse.h gstopusheader.h