summaryrefslogtreecommitdiff
path: root/ext/qt/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/qt/Makefile.am')
-rw-r--r--ext/qt/Makefile.am60
1 files changed, 0 insertions, 60 deletions
diff --git a/ext/qt/Makefile.am b/ext/qt/Makefile.am
deleted file mode 100644
index cf2f761c3..000000000
--- a/ext/qt/Makefile.am
+++ /dev/null
@@ -1,60 +0,0 @@
-plugin_LTLIBRARIES = libgstqmlgl.la
-
-noinst_HEADERS = \
- gstqsgtexture.h \
- gstqtglutility.h \
- gstqtsink.h \
- gstqtsrc.h \
- qtitem.h \
- qtwindow.h
-
-moc_generated = \
- moc_qtitem.cc \
- moc_qtwindow.cc \
- moc_gstqsgtexture.cc
-
-#anything generated by the Qt tools...
-BUILT_SOURCES = $(moc_generated)
-CLEANFILES = $(moc_generated)
-
-nodist_libgstqmlgl_la_SOURCES = $(BUILT_SOURCES)
-
-libgstqmlgl_la_SOURCES = \
- gstqsgtexture.cc \
- gstqtglutility.cc \
- qtitem.cc \
- qtwindow.cc \
- gstqtsink.cc \
- gstqtsink.h \
- gstqtsrc.cc \
- gstqtsrc.h \
- gstqtgl.h \
- gstplugin.cc
-
-libgstqmlgl_la_CXXFLAGS = \
- $(GST_PLUGINS_BAD_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS) \
- $(GST_GL_CFLAGS) \
- $(GST_BASE_CFLAGS) \
- $(GST_CXXFLAGS) \
- $(QT_CFLAGS) \
- $(GL_CFLAGS) -std=c++11
-
-libgstqmlgl_la_LIBADD = \
- $(GST_PLUGINS_BASE_LIBS) \
- $(GST_GL_LIBS) \
- -lgstvideo-$(GST_API_VERSION) \
- $(GST_BASE_LIBS) \
- $(QT_LIBS)
-
-libgstqmlgl_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-
-
-$(moc_generated): moc_%.cc: %.h
- @MOC@ -o $@ $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(MOC_CPPFLAGS) $<
-
-ui-%.h: %.ui
- @UIC@ -o $@ $<
-
-qrc-%.cc: %.qrc
- @RCC@ -o $@ $<