summaryrefslogtreecommitdiff
path: root/ext/srtp/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/srtp/meson.build')
-rw-r--r--ext/srtp/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/ext/srtp/meson.build b/ext/srtp/meson.build
index 0a296869a..3ce67827f 100644
--- a/ext/srtp/meson.build
+++ b/ext/srtp/meson.build
@@ -13,8 +13,8 @@ srtp_dep = dependency('libsrtp2', version : '>= 2.1.0', required : false)
if srtp_dep.found()
srtp_cargs += ['-DHAVE_SRTP2']
else
- srtp_dep = dependency('libsrtp', required : false)
- if not srtp_dep.found() and cc.has_header_symbol('srtp/srtp.h', 'srtp_init')
+ srtp_dep = dependency('libsrtp', version: '>= 1.6.0', required : false)
+ if not srtp_dep.found() and cc.has_header_symbol('srtp/srtp.h', 'crypto_policy_set_aes_gcm_128_16_auth')
srtp_dep = cc.find_library('srtp', required : false)
endif
endif