summaryrefslogtreecommitdiff
path: root/gst-libs/ext/ffmpeg/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/ext/ffmpeg/Makefile.am')
-rw-r--r--gst-libs/ext/ffmpeg/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/gst-libs/ext/ffmpeg/Makefile.am b/gst-libs/ext/ffmpeg/Makefile.am
index 3a9af8dd0..102065da4 100644
--- a/gst-libs/ext/ffmpeg/Makefile.am
+++ b/gst-libs/ext/ffmpeg/Makefile.am
@@ -7,9 +7,22 @@ else
FFMPEG_DIR=
endif
+# patch it up
+all-am: Makefile patches
+
+# ignore failures on patching
+# ignore failures on rm
+PATCHES = patch/function.patch
+
+patches:
+ @patch -p0 -N -r rejects < patch/function.patch > /dev/null || true
+ @rm -f rejects || true
+
+
SUBDIRS = $(FFMPEG_DIR)
DISTFILES = \
+ $(PATCHES) \
Tag \
ffmpeg/CVS/Tag \
ffmpeg/Changelog \