summaryrefslogtreecommitdiff
path: root/gst/hls/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/hls/Makefile.am')
-rw-r--r--gst/hls/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gst/hls/Makefile.am b/gst/hls/Makefile.am
index 77638cb58..687b568e0 100644
--- a/gst/hls/Makefile.am
+++ b/gst/hls/Makefile.am
@@ -16,3 +16,17 @@ noinst_HEADERS = \
gstfragmented.h \
gsthlsdemux.h \
m3u8.h
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgsthls -:SHARED libgsthls \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgsthls_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgsthls_la_CFLAGS) \
+ -:LDFLAGS $(libgsthls_la_LDFLAGS) \
+ $(libgsthls_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@