summaryrefslogtreecommitdiff
path: root/gst/librfb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/librfb/Makefile.am')
-rw-r--r--gst/librfb/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gst/librfb/Makefile.am b/gst/librfb/Makefile.am
index 351beeeca..ad4dd4fb6 100644
--- a/gst/librfb/Makefile.am
+++ b/gst/librfb/Makefile.am
@@ -26,3 +26,17 @@ noinst_HEADERS = \
gstrfbsrc.h \
d3des.h \
vncauth.h
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstlibrfb -:SHARED libgstlibrfb \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstlibrfb_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstlibrfb_la_CFLAGS) \
+ -:LDFLAGS $(libgstlibrfb_la_LDFLAGS) \
+ $(libgstlibrfb_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@