summaryrefslogtreecommitdiff
path: root/gst/mpegpsmux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/mpegpsmux/Makefile.am')
-rw-r--r--gst/mpegpsmux/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/gst/mpegpsmux/Makefile.am b/gst/mpegpsmux/Makefile.am
new file mode 100644
index 000000000..221a61230
--- /dev/null
+++ b/gst/mpegpsmux/Makefile.am
@@ -0,0 +1,23 @@
+plugin_LTLIBRARIES = libgstmpegpsmux.la
+
+libgstmpegpsmux_la_SOURCES = \
+ mpegpsmux.c \
+ psmux.c \
+ psmuxstream.c \
+ mpegpsmux_aac.c \
+ mpegpsmux_h264.c
+
+libgstmpegpsmux_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CLFAGS)
+libgstmpegpsmux_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS)
+libgstmpegpsmux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstmpegpsmux_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = \
+ mpegpsmux.h \
+ psmux.h \
+ psmuxstream.h \
+ psmuxcommon.h \
+ mpegpsmux_aac.h \
+ mpegpsmux_h264.h \
+ bits.h \
+ crc.h