summaryrefslogtreecommitdiff
path: root/gst/scaletempo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/scaletempo/Makefile.am')
-rw-r--r--gst/scaletempo/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/gst/scaletempo/Makefile.am b/gst/scaletempo/Makefile.am
index c54502b68..092a7eb05 100644
--- a/gst/scaletempo/Makefile.am
+++ b/gst/scaletempo/Makefile.am
@@ -12,3 +12,17 @@ libgstscaletempoplugin_la_LIBTOOLFLAGS = --tag=disable-static
# headers we need but don't want installed
noinst_HEADERS = gstscaletempo.h
+
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstscaletempo -:SHARED libgstscaletempo \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstscaletempo_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstscaletempo_la_CFLAGS) \
+ -:LDFLAGS $(libgstscaletempo_la_LDFLAGS) \
+ $(libgstscaletempo_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@