summaryrefslogtreecommitdiff
path: root/gst/videomaxrate/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/videomaxrate/Makefile.am')
-rw-r--r--gst/videomaxrate/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/gst/videomaxrate/Makefile.am b/gst/videomaxrate/Makefile.am
index 595941ed5..cf21139c8 100644
--- a/gst/videomaxrate/Makefile.am
+++ b/gst/videomaxrate/Makefile.am
@@ -9,3 +9,16 @@ libgstvideomaxrate_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) $(GST_BASE_LIBS) \
libgstvideomaxrate_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstvideomaxrate_la_LIBTOOLFLAGS = --tag=disable-static
+Android.mk: Makefile.am $(BUILT_SOURCES)
+ androgenizer \
+ -:PROJECT libgstvideomaxrate -:SHARED libgstvideomaxrate \
+ -:TAGS eng debug \
+ -:REL_TOP $(top_srcdir) -:ABS_TOP $(abs_top_srcdir) \
+ -:SOURCES $(libgstvideomaxrate_la_SOURCES) \
+ -:CFLAGS $(DEFS) $(DEFAULT_INCLUDES) $(libgstvideomaxrate_la_CFLAGS) \
+ -:LDFLAGS $(libgstvideomaxrate_la_LDFLAGS) \
+ $(libgstvideomaxrate_la_LIBADD) \
+ -ldl \
+ -:PASSTHROUGH LOCAL_ARM_MODE:=arm \
+ LOCAL_MODULE_PATH:='$$(TARGET_OUT)/lib/gstreamer-0.10' \
+ > $@ \ No newline at end of file