summaryrefslogtreecommitdiff
path: root/sys/applemedia/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/applemedia/Makefile.am')
-rw-r--r--sys/applemedia/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys/applemedia/Makefile.am b/sys/applemedia/Makefile.am
index 4e415249d..f1e678558 100644
--- a/sys/applemedia/Makefile.am
+++ b/sys/applemedia/Makefile.am
@@ -92,16 +92,22 @@ libgstapplemedia_la_LDFLAGS += \
else
libgstapplemedia_la_SOURCES += \
- qtkitvideosrc.m \
iosurfacememory.c
libgstapplemedia_la_LDFLAGS += \
-Wl,-framework -Wl,Cocoa \
- -Wl,-framework -Wl,QTKit \
-Wl,-framework -Wl,IOSurface
endif
+if HAVE_QTKIT
+libgstapplemedia_la_SOURCES += \
+ qtkitvideosrc.m
+
+libgstapplemedia_la_LDFLAGS += \
+ -Wl,-framework -Wl,QTKit
+endif
+
if HAVE_AVFOUNDATION
libgstapplemedia_la_SOURCES += \