summaryrefslogtreecommitdiff
path: root/sys/fbdev/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'sys/fbdev/meson.build')
-rw-r--r--sys/fbdev/meson.build11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys/fbdev/meson.build b/sys/fbdev/meson.build
index 1aed2ad38..84ee057f0 100644
--- a/sys/fbdev/meson.build
+++ b/sys/fbdev/meson.build
@@ -2,7 +2,16 @@ fbdevsink_sources = [
'gstfbdevsink.c',
]
-if cc.has_header('linux/fb.h')
+if get_option('fbdev').disabled()
+ subdir_done()
+endif
+
+have_fb_h = cc.has_header('linux/fb.h')
+if not have_fb_h and get_option('fbdev').enabled()
+ error('fbdev plugin enabled but fb.h not found')
+endif
+
+if have_fb_h
gstfbdevsink = library('gstfbdevsink',
fbdevsink_sources,
c_args : gst_plugins_bad_args,