summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 0658f0153..aababe779 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,3 +1,9 @@
+if HAVE_CHECK
+SUBDIRS_CHECK = check
+else
+SUBDIRS_CHECK =
+endif
+
if USE_X
SUBDIRS_ICLES = icles
else
@@ -5,7 +11,9 @@ SUBDIRS_ICLES =
endif
SUBDIRS = \
+ $(SUBDIRS_CHECK) \
$(SUBDIRS_ICLES)
DIST_SUBDIRS = \
+ check \
icles