summaryrefslogtreecommitdiff
path: root/tests/examples/gl/cocoa/videooverlay/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples/gl/cocoa/videooverlay/Makefile.am')
-rwxr-xr-xtests/examples/gl/cocoa/videooverlay/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/examples/gl/cocoa/videooverlay/Makefile.am b/tests/examples/gl/cocoa/videooverlay/Makefile.am
new file mode 100755
index 000000000..47dac610c
--- /dev/null
+++ b/tests/examples/gl/cocoa/videooverlay/Makefile.am
@@ -0,0 +1,14 @@
+if HAVE_WINDOW_COCOA
+
+noinst_PROGRAMS = videooverlay
+
+videooverlay_SOURCES = main.m
+
+videooverlay_OBJCFLAGS=$(GST_PLUGINS_GL_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) \
+ $(GL_CFLAGS) -I/usr/local/include/gstreamer-${GST_API_VERSION} ${GL_OBJCFLAGS}
+videooverlay_LDADD=$(GST_PLUGINS_GL_LIBS) $(GST_PLUGINS_BASE_LIBS) $(GST_LIBS) \
+ $(GL_LIBS) -lgstvideo-$(GST_API_VERSION)
+
+videooverlay_LIBTOOLFLAGS = --tag=OBJC
+
+endif