summaryrefslogtreecommitdiff
path: root/tests/examples/gl/gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples/gl/gtk/Makefile.am')
-rw-r--r--tests/examples/gl/gtk/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/examples/gl/gtk/Makefile.am b/tests/examples/gl/gtk/Makefile.am
new file mode 100644
index 000000000..c64cd4a38
--- /dev/null
+++ b/tests/examples/gl/gtk/Makefile.am
@@ -0,0 +1,12 @@
+
+SUBDIRS = . gtkvideooverlay filternovideooverlay filtervideooverlay fxtest switchvideooverlay
+
+noinst_LTLIBRARIES = libgstgtkhelper.la
+
+libgstgtkhelper_la_SOURCES = gstgtk.c gstgtk.h
+libgstgtkhelper_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS) $(GTK3_CFLAGS)
+
+if HAVE_WINDOW_COCOA
+libgstgtkhelper_la_CFLAGS += -x objective-c
+endif
+