summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-09-19 11:45:59 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-09-19 11:45:59 +0100
commit03a8e6af7206017633fe60b9f0ce4e8435344bf8 (patch)
tree7a1e6d928af4aef881d344d0c172872979e23c35 /meson.build
parent04cb304b2dfaf3f97994476dcf56d38a5421a96c (diff)
downloadgstreamer-plugins-good-03a8e6af7206017633fe60b9f0ce4e8435344bf8.tar.gz
meson: add glib-checks option to disable API guards and such
We want this enabled by default, also in releases, but people may want to disable this for performance-critical workloads or on embedded devices.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index a37c7c4e4..b248e016c 100644
--- a/meson.build
+++ b/meson.build
@@ -80,6 +80,12 @@ if glib_asserts.disabled() or (glib_asserts.auto() and not gst_version_is_dev)
add_project_arguments('-DG_DISABLE_ASSERT', language: 'c')
endif
+glib_checks = get_option('glib-checks')
+if glib_checks.disabled() or (glib_checks.auto() and not gst_version_is_dev)
+ message('Disabling GLib checks')
+ add_project_arguments('-DG_DISABLE_CHECKS', language: 'c')
+endif
+
cdata = configuration_data()
check_headers = [