summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha@centricular.com>2020-06-19 19:54:08 +0900
committerSeungha Yang <seungha@centricular.com>2020-06-19 19:54:08 +0900
commit154146b9cc154f4fdecb4c48041bf44b605b125e (patch)
treec2c3d93eb999b0ef9d34edbb1455cb4bb258ac2d /meson.build
parent8c8b788f73b4953e8a91b7bedd6597f5a92b16b8 (diff)
downloadgstreamer-plugins-good-154146b9cc154f4fdecb4c48041bf44b605b125e.tar.gz
meson: Fix build error with MSVC caused by ARCH_X86_64 define
ARCH_X86_64 define will enable GCC specific code path in dv_types.h while building dv plugin. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-good/-/merge_requests/636>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 0 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7bb064577..74d3f050a 100644
--- a/meson.build
+++ b/meson.build
@@ -418,7 +418,6 @@ if find_program('xgettext', required : get_option('nls')).found()
subdir('po')
endif
-cdata.set10('ARCH_X86_64', host_cpu == 'x86_64')
configure_file(output : 'config.h', configuration : cdata)
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')