summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-12-18 20:39:40 +0900
committerSeungha Yang <seungha.yang@navercorp.com>2018-12-18 22:52:24 +0900
commit16af121a86e5b792b21129c820b32dc67b1c8ede (patch)
treeed6d653424edfb071c7490a9f651efcc2bccd589 /meson.build
parent9a3e8ad2d7b12446ba92307b15779fa9fe819bac (diff)
downloadgstreamer-plugins-good-16af121a86e5b792b21129c820b32dc67b1c8ede.tar.gz
meson: Prefer to use join_paths() over '/'
... to avoid mixing '/' and '\' in a path string on Windows.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 6d5720583..f3f880049 100644
--- a/meson.build
+++ b/meson.build
@@ -25,7 +25,7 @@ gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
api_version = '1.0'
-plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
+plugins_install_dir = join_paths(get_option('libdir'), 'gstreamer-1.0')
cc = meson.get_compiler('c')
host_system = host_machine.system()