summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-11-24 19:13:28 +0900
committerSeungha Yang <seungha.yang@navercorp.com>2018-11-24 20:16:30 +0900
commit69ad6af83c48b9a06fb2d47df8fc342234eb5c8e (patch)
treed5d5bec2f5ab2a82746b07ff97b0ff824b38f905 /meson.build
parent5fad0735a56b6d70bd6170db19eec4210df5ce67 (diff)
downloadgstreamer-plugins-good-69ad6af83c48b9a06fb2d47df8fc342234eb5c8e.tar.gz
meson: Specify encoding to UTF-8 when building with MSVC
Use build arguments consistent with core and -base. This can also remove noisy "C4819" warning of non-us locale MSVC.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 216070836..6d5720583 100644
--- a/meson.build
+++ b/meson.build
@@ -40,6 +40,7 @@ if cc.get_id() == 'msvc'
'/wd4146', # unary minus on unsigned (beware INT_MIN)
'/wd4244', # lossy type conversion (e.g. double -> int)
'/wd4305', # truncating type conversion (e.g. double -> float)
+ cc.get_supported_arguments(['/utf-8']), # set the input encoding to utf-8
language : 'c')
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW