summaryrefslogtreecommitdiff
path: root/gst-libs/ext/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2007-12-17 12:43:06 +0000
committerEdward Hervey <bilboed@bilboed.com>2007-12-17 12:43:06 +0000
commitf6186655c5507c6cc1bbce09b397e6d89078205b (patch)
treec1ea2763ff3343957140be924d45955ab1ee6438 /gst-libs/ext/Makefile.am
parent22e3b86e43542e3cf36ffb3cd758495706cc0e20 (diff)
downloadgstreamer-f6186655c5507c6cc1bbce09b397e6d89078205b.tar.gz
Merging GST_FFMPEG_NO_MIRROR branch to trunk
Original commit message from CVS: Merging GST_FFMPEG_NO_MIRROR branch to trunk
Diffstat (limited to 'gst-libs/ext/Makefile.am')
-rw-r--r--gst-libs/ext/Makefile.am42
1 files changed, 41 insertions, 1 deletions
diff --git a/gst-libs/ext/Makefile.am b/gst-libs/ext/Makefile.am
index 137ab3a78c..67b79f84f9 100644
--- a/gst-libs/ext/Makefile.am
+++ b/gst-libs/ext/Makefile.am
@@ -8,8 +8,48 @@
# - add an all-local hook so it does get built
# this also satisfies make distcheck
-SUBDIRS =
+SUBDIRS =
DIST_SUBDIRS = ffmpeg
+TMP_DIST_DIR=ffmpeg-dist
+DIST_DIR=$(TMP_DIST_DIR)/.ffmpeg
all-local:
cd ffmpeg && $(MAKE)
+
+clean-local:
+ cd ffmpeg && $(MAKE) distclean
+
+dist-clean:
+ rm -rf $(TMP_DIST_DIR)
+
+dist-local: dist-clean
+ svn -r $(FFMPEG_REVISION) co $(FFMPEG_SVN) $(TMP_DIST_DIR)
+ mkdir $(DIST_DIR)
+ pwd
+ cp $(TMP_DIST_DIR)/*.c $(TMP_DIST_DIR)/*.h $(TMP_DIST_DIR)/Makefile $(TMP_DIST_DIR)/configure $(TMP_DIST_DIR)/version.sh $(DIST_DIR)
+ cp $(TMP_DIST_DIR)/common.mak $(TMP_DIST_DIR)/Changelog $(TMP_DIST_DIR)/COPYING.* $(TMP_DIST_DIR)/INSTALL $(DIST_DIR)
+ cp $(TMP_DIST_DIR)/Doxyfile $(TMP_DIST_DIR)/ffinstall.nsi $(TMP_DIST_DIR)/CREDITS $(TMP_DIST_DIR)/MAINTAINERS $(DIST_DIR)
+ @for d in `cd $(TMP_DIST_DIR) && ls -d */`; \
+ do mkdir $(DIST_DIR)/$$d; \
+ cp $(TMP_DIST_DIR)/$$d* $(DIST_DIR)/$$d; \
+ if [ `ls -d $(TMP_DIST_DIR)/$$d*/ | wc -w` != "" ]; \
+ then for id in `cd $(TMP_DIST_DIR)/$$d && ls -d */`; \
+ do mkdir $(DIST_DIR)/$$d$$id; \
+ cp $(TMP_DIST_DIR)/$$d$$id/*.c $(TMP_DIST_DIR)/$$d$$id/*.h $(DIST_DIR)/$$d$$id; \
+ done \
+ fi \
+ done
+ rm -rf ffmpeg
+ mv $(DIST_DIR) ffmpeg
+ echo "Patching ffmpeg ./configure"
+ sed -e '/Unknown option/ {N;N;s/exit 1//; }' ffmpeg/configure > ffmpeg/configure.tmp
+ mv ffmpeg/configure.tmp ffmpeg/configure
+ chmod +x ffmpeg/configure
+ rm -rf $(TMP_DIST_DIR)
+
+distdir: dist-local
+ cp -r ffmpeg Makefile* ${distdir}
+
+dist: dist-local
+ tar -czf ffmpeg.tar.gz ffmpeg
+