summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorOwen Taylor <owt1@cornell.edu>1998-03-30 23:04:51 +0000
committerOwen Taylor <otaylor@src.gnome.org>1998-03-30 23:04:51 +0000
commit4bf5d761bcb86ee9c60bceda9f93e8115ed4b785 (patch)
tree1475e5f4bcccc50b1c7e182229e804fae43140a8 /configure.in
parent8eb7761e7207644568885bca22d413eb75b4dc3c (diff)
downloadgtk+-4bf5d761bcb86ee9c60bceda9f93e8115ed4b785.tar.gz
Improved main loop test. (Quits main loop properly, makes it more obvious
Mon Mar 30 16:35:57 1998 Owen Taylor <owt1@cornell.edu> * gtk/testgtk.c: Improved main loop test. (Quits main loop properly, makes it more obvious to the user what is going on) * gtk/gtkwidget.c (gtk_widget_unparent): Reset the allocation _after_ clearing the window. * configure.in: If can't find XShmAttach in Xext, check in XextSam (for AIX). * gtk/gtkmain.c (gtk_events_pending): Remember, small numbers are _high_ priority for idle queues. * gtk/gtkmain.c (gtk_handle_current_timeouts): Allow removing the currently running timeout. * gtk/testgtk.c (timeout_test): Use the right prototype for callback.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 7fcebc3273..0814ce0b88 100644
--- a/configure.in
+++ b/configure.in
@@ -109,7 +109,13 @@ AC_CHECK_LIB(X11, XOpenDisplay, x_libs="-lX11 $X_EXTRA_LIBS", no_x11_lib=yes, $X
if test "x$enable_shm" = "xyes"; then
# Check for the Xext library (needed for XShm extention)
- AC_CHECK_LIB(Xext, XShmAttach, x_libs="-lXext $x_libs", no_xext_lib=yes, $x_libs)
+ AC_CHECK_LIB(Xext, XShmAttach,
+ x_libs="-lXext $x_libs",
+ # On AIX, it is in XextSam instead, but we still need -lXext
+ AC_CHECK_LIB(XextSam, XShmAttach,
+ x_libs="-lXextSam -lXext $x_libs",
+ no_xext_lib=yes, $x_libs),
+ $x_libs)
fi
x_cflags="$X_CFLAGS"