summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorРуслан Ижбулатов <lrn1986@gmail.com>2014-09-09 14:48:17 +0000
committerBenjamin Otte <otte@redhat.com>2014-09-15 16:35:40 +0200
commit45ab4ae09bade6f63bc71d4df0aa250c72afe1b2 (patch)
tree75655b456f0f90a4127634d43439aae4afd82b6a /gtk/Makefile.am
parent1741de47dbd4ddb909012fb977f19bd1417fddea (diff)
downloadgtk+-45ab4ae09bade6f63bc71d4df0aa250c72afe1b2.tar.gz
build: Set no_undefined in Makefile.decl
This simplifies the code and - more importantly - fixes the cases like in testsuite/reftests where the no_undefined definition was missing. https://bugzilla.gnome.org/show_bug.cgi?id=736382
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 2ec3cd2957..17ca614292 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -79,10 +79,6 @@ AM_CPPFLAGS = \
$(GTK_DEP_CFLAGS) \
$(INCLUDED_IMMODULE_DEFINE)
-if PLATFORM_WIN32
-no_undefined = -no-undefined
-endif
-
if OS_WIN32
gtk_def = gtk.def
gtk_win32_symbols = -export-symbols $(srcdir)/gtk.def