summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2012-04-11 16:00:57 +0200
committerBenjamin Otte <otte@redhat.com>2012-04-17 08:59:23 +0200
commit7b7027c971d07ac54844b1fc022f5f14d26ce875 (patch)
tree5e17a42e34d3e90d3e101d7b10b62d2ac22b89b8 /gtk/Makefile.am
parent8b1385804e049d6e691462224ed928d15c5b8dc6 (diff)
downloadgtk+-7b7027c971d07ac54844b1fc022f5f14d26ce875.tar.gz
stylecontext: Add new class for animation handling
A StyleAnimation is an immutable object used to track the state of CSS values. I'd have liked to make it fully immutable - ie not have the timestamp in there - but couldn't find a place to sanely store the timestamp. This is an abstract base class. Implementations for this will be added later (for both CSS3 transitions and animations, potentially for animated images). Actually aplying the information in this object will be done by a different object commtted later.
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index cc9c3020f1..f8e4c32c13 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -508,6 +508,7 @@ gtk_private_h_sources = \
gtksettingsprivate.h \
gtksizegroup-private.h \
gtksocketprivate.h \
+ gtkstyleanimationprivate.h \
gtkstylecascadeprivate.h \
gtkstylecontextprivate.h \
gtkstylepropertiesprivate.h \
@@ -791,6 +792,7 @@ gtk_base_c_sources = \
gtkstatusbar.c \
gtkstatusicon.c \
gtkstock.c \
+ gtkstyleanimation.c \
gtkstylecascade.c \
gtkstylecontext.c \
gtkstyleproperties.c \