summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorBastien Nocera <hadess@hadess.net>2012-05-29 18:39:37 +0100
committerMatthias Clasen <mclasen@redhat.com>2012-05-30 13:46:40 -0400
commit9d35f7e5121c863685375d1afb7e14e886e46348 (patch)
tree6e5b6e14f6fe3c819a2546ec2fe9547fb388b94e /gtk/Makefile.am
parent1519a1e8c295bc1c97e765d4cee0f866bf8398c6 (diff)
downloadgtk+-9d35f7e5121c863685375d1afb7e14e886e46348.tar.gz
gtkmenubutton: Add menu button widget
As used in Totem and gnome-contacts. The widget takes either a GtkMenu or a GMenuModel to construct its menu, and can be given a parent widget to use to position the drop-down (as used in GtkMenuToolButton). https://bugzilla.gnome.org/show_bug.cgi?id=668013
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index dfa90ac36d..99c8432f6a 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -271,6 +271,7 @@ gtk_public_h_sources = \
gtkmain.h \
gtkmenu.h \
gtkmenubar.h \
+ gtkmenubutton.h \
gtkmenuitem.h \
gtkmenushell.h \
gtkmenutoolbutton.h \
@@ -479,6 +480,7 @@ gtk_private_h_sources = \
gtkimcontextsimpleseqs.h \
gtkintl.h \
gtkkeyhash.h \
+ gtkmenubuttonprivate.h \
gtkmenuprivate.h \
gtkmenuitemprivate.h \
gtkmenushellprivate.h \
@@ -731,6 +733,7 @@ gtk_base_c_sources = \
gtkmarshalers.c \
gtkmenu.c \
gtkmenubar.c \
+ gtkmenubutton.c \
gtkmenuitem.c \
gtkmenushell.c \
gtkmenutoolbutton.c \