summaryrefslogtreecommitdiff
path: root/meson_options.txt
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-03-23 15:54:58 +0000
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-03 15:10:56 +0100
commite8509739564e278b2c35a69c75d4dde1ba9b0ab7 (patch)
tree515775e30d9cc0d4723b8ecdbc7b6d9c8f7987b9 /meson_options.txt
parent1c14e93e691088d2685011641031180f66989561 (diff)
downloadgtk+-e8509739564e278b2c35a69c75d4dde1ba9b0ab7.tar.gz
meson: build input modules
We have to work around some ordering problems here. We still manage to keep most of the guts in modules/input/meson.build, so it's not too ugly overall. (The autotools build solves this with a 'make -C ../../input/modules' inside gtk/Makefile, but that's not something we can or want to do.)
Diffstat (limited to 'meson_options.txt')
-rw-r--r--meson_options.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson_options.txt b/meson_options.txt
index bf80420ceb..d23e319e4c 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -20,3 +20,7 @@ option('enable-cloudprint-print-backend', type: 'combo', choices : ['yes', 'no',
description : 'Enable the cloudprint print backend')
option('enable-xinerama', type: 'combo', choices : ['yes', 'no', 'auto'], value : 'auto',
description : 'Enable support for the Xinerama extension')
+option('disable-modules', type: 'boolean', value : 'false',
+ description : 'Disable dynamic module loading')
+option('with-included-immodules', type: 'string', value : '',
+ description : 'Build the specified input methods into gtk (comma-separated list or "all" or "none")')