summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorTim Janik <timj@imendio.com>2007-06-22 10:16:39 +0000
committerTim Janik <timj@src.gnome.org>2007-06-22 10:16:39 +0000
commit9d21e46190e53bcd03e48bdf4bf45052bf3807d0 (patch)
treee573fd487f8398a2f4899aa62a2b5bf06952090d /tests/Makefile.am
parente7525262bd01901459a3a4b2e417083475426465 (diff)
downloadgtk+-9d21e46190e53bcd03e48bdf4bf45052bf3807d0.tar.gz
applied patch from Xan Lopez to eliminate gap in painted frame for
Fri Jun 22 12:13:39 2007 Tim Janik <timj@imendio.com> * gtk/gtkframe.c (gtk_frame_paint): applied patch from Xan Lopez to eliminate gap in painted frame for yaling=0.0 or yalign=1.0. * tests/testframe.c: added test application from Xan Lopez to test xalign/yalign interactions with xthickness/ythickness. svn path=/trunk/; revision=18216
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eed40262d8..582b83f75f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -45,6 +45,7 @@ noinst_PROGRAMS = \
testentrycompletion \
testfilechooser \
testfilechooserbutton \
+ testframe \
testgtk \
testiconview \
testicontheme \
@@ -99,6 +100,7 @@ testiconview_DEPENDENCIES = $(TEST_DEPS)
testaccel_DEPENDENCIES = $(TEST_DEPS)
testassistant_DEPENDENCIES = $(TEST_DEPS)
testbbox_DEPENDENCIES = $(TEST_DEPS)
+testframe_DEPENDENCIES = $(TEST_DEPS)
testcairo_DEPENDENCIES = $(TEST_DEPS)
testcalendar_DEPENDENCIES = $(TEST_DEPS)
testcombo_DEPENDENCIES = $(TEST_DEPS)
@@ -153,6 +155,7 @@ print_editor_LDADD = $(LDADDS)
testaccel_LDADD = $(LDADDS)
testassistant_LDADD = $(LDADDS)
testbbox_LDADD = $(LDADDS)
+testframe_LDADD = $(LDADDS)
testcairo_LDADD = $(LDADDS)
testcalendar_LDADD = $(LDADDS)
testcombo_LDADD = $(LDADDS)
@@ -276,6 +279,9 @@ testactions_SOURCES = \
testbbox_SOURCES = \
testbbox.c
+testframe_SOURCES = \
+ testframe.c
+
testiconview_SOURCES = \
testiconview.c \
prop-editor.c