summaryrefslogtreecommitdiff
path: root/gdk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gdk/Makefile.am')
-rw-r--r--gdk/Makefile.am75
1 files changed, 75 insertions, 0 deletions
diff --git a/gdk/Makefile.am b/gdk/Makefile.am
new file mode 100644
index 0000000000..f298e2c3a1
--- /dev/null
+++ b/gdk/Makefile.am
@@ -0,0 +1,75 @@
+## Process this file with automake to produce Makefile.in
+
+gdkincludedir = $(includedir)/gdk
+
+lib_LTLIBRARIES = libgdk.la
+
+libgdk_la_SOURCES = \
+ gdk.c \
+ gdkcolor.c \
+ gdkcursor.c \
+ gdkdraw.c \
+ gdkfont.c \
+ gdkgc.c \
+ gdkglobals.c \
+ gdkimage.c \
+ gdkinput.c \
+ gdkpixmap.c \
+ gdkproperty.c \
+ gdkrectangle.c \
+ gdkselection.c \
+ gdkvisual.c \
+ gdkwindow.c \
+ gdkxid.c \
+ gxid_lib.c
+## this last one is ifdef'd out unless XINPUT_GXI is defined
+## It's easier than trying to get automake to handle compiling
+## it conditionally
+
+gdkinclude_HEADERS = \
+ gdk.h \
+ gdkcursors.h \
+ gdkkeysyms.h \
+ gdkprivate.h \
+ gdktypes.h \
+ gdkinput.h \
+ gdkinputnone.h \
+ gdkinputcommon.h\
+ gdkinputgxi.h \
+ gdkinputxfree.h \
+ gxid_lib.h \
+ gxid_proto.h \
+ gdkx.h
+
+libgdk_la_LDFLAGS = -version-info 1:0:0 \
+ @x_ldflags@ @x_libs@
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/glib @x_cflags@
+
+EXTRA_PROGRAMS = gxid
+
+bin_PROGRAMS = @xinput_progs@
+
+gxid_SOURCES = gxid.c
+
+gxid_LDADD = \
+ @x_ldflags@ \
+ @x_libs@ \
+ -lm
+
+BUILT_SOURCES = gdkcursors.h gdkkeysyms.h
+
+EXTRA_DIST = makecursors makecursors.sed makekeysyms makekeysyms.sed
+
+gdkcursors.h:
+ $(srcdir)/makecursors @x_includes@/X11/cursorfont.h > $@
+
+gdkkeysyms.h:
+ $(srcdir)/makekeysyms @x_includes@/X11/keysymdef.h > $@
+
+.PHONY: files
+
+files:
+ @files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
+ echo $$p; \
+ done