summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Allow single line GtkSpreadTablespread-tableTristan Van Berkom2010-10-112-35/+50
| | | | | Added exception for single line spread table and updated test case to allow configuration to a single line.
* Added gtk_spread_table_get_child_lineTristan Van Berkom2010-10-092-1/+63
| | | | | | | | | | Gets the line index in which a child would be positioned if the table were to be allocated size in the opposing orientation of the table. For instance, if the table is oriented vertically, this function will return the child's column if the table were to be allocated size width.
* Changed GtkSpreadTable algorithm to be a binary search for the best heightTristan Van Berkom2010-10-081-196/+92
| | | | | | | | | | This has some exceptions: - We still ignore the height of a widget that spans the entire column (i.e. large images dont force the whole table to try to be as tall as the image itself) - In this new algorithm we fill in to the best height from left to right which can leave trailing empty columns; in this case we place only a single widget in each trailing column.
* Added GtkSpreadTable widget and test case.Tristan Van Berkom2010-10-067-1/+1661
| | | | | | | | | | GtkSpreadTable positions its children by distributing them as evenly as possible across a fixed number of rows or columns. When oriented vertically the GtkSpreadTable will list its children in order from top to bottom in columns and request the smallest height as possible regardless of differences in child sizes.
* Enhanced documentation description for GtkWrapBox (text by Murray Cumming).Tristan Van Berkom2010-10-061-3/+12
|
* Updates for Kazakh translationBaurzhan Muftakhidinov2010-10-061-936/+941
|
* Replace GDK_Tab and GDK_ISO_Left_Tab with GDK_KEY equivalentsJohn Ralls2010-10-062-6/+6
| | | | | | Fixes https://bugzilla.gnome.org/show_bug.cgi?id=631475 Signed-off-by: Javier Jardón <jjardon@gnome.org>
* docs: visuals: Do not mention deprecated GdkRGB API'sJavier Jardón2010-10-061-6/+2
| | | | | Reported by Milan Bouchet-Valat in bug https://bugzilla.gnome.org/show_bug.cgi?id=631473
* docs: Dn't mark all signals in GtkWidgetClass as privateBenjamin Otte2010-10-051-4/+0
| | | | They are meant to be overwritten by subclasses after all.
* viewport: Clip contents properly when called via gtk_widget_draw()Benjamin Otte2010-10-051-0/+15
|
* Revert "testgtk: Remove snapshot test"Benjamin Otte2010-10-051-0/+167
| | | | | | This reverts commit 99c82af20a5204940ce2cb0f841be0d6f70a2778 and fixes up things to compile again. Of course, the snapshotting now uses gtk_widget_draw() instead.
* docs: reword GtkAdjustment short descriptionJavier Jardón2010-10-051-1/+1
|
* Handle the case where you type /blah/nonexistent in SELECT_FOLDER modeFederico Mena Quintero2010-10-051-1/+6
| | | | | | | | | Previously name_entry_get_parent_info_cb() would fail as it doesn't handle SELECT_FOLDER. Now we just make that function act the same as for CREATE_FOLDER mode. In either case, if you type "/blah/nonexistent" and hit Enter, you want a folder with that name to be created (under the already-existing /blah). Signed-off-by: Federico Mena Quintero <federico@novell.com>
* Clarify the name of a callbackStephen Shaw2010-10-051-6/+8
| | | | | | | | The old save_entry_get_info_cb() was misnamed; it is actually used to see if a file's presumed parent *is* a folder. So we rename it to name_entry_get_parent_info_cb(). Signed-off-by: Federico Mena Quintero <federico@novell.com>
* bgo#629722 - file chooser should cope with typing a directory name and then ↵Stephen Shaw2010-10-051-17/+70
| | | | | | | | | | | | | | Enter file_exists_get_info_cb() used to let some actions fall through to the code that checks for the file type of the selected file's parent (e.g. to see if /foo/bar *is* indeed a folder if you type /foo/bar/baz). However, we need to be more explicit for each file chooser action, as in SELECT_FOLDER mode typing /foo/foldername and hitting Enter would not give you an immediate selection, but rather the file chooser would complain that it couldn't create that directory as it already exists. Signed-off-by: Federico Mena Quintero <federico@novell.com>
* Added Kikongo translationKibavuidi Nsiangani2010-10-053-0/+15684
|
* Make set_cairo_surface_size a vfunc on GdkWindowImplKristian Rietveld2010-10-0510-37/+65
| | | | | Note the special implementation of this method on GdkOffscreenWindow that makes sure its current surface is not destroyed.
* tests: don't call gtk_widget_get_allocation() on NULL childrenMichael Natterer2010-10-051-4/+9
|
* gtkmenu: Really fix menu codeJavier Jardón2010-10-041-1/+1
| | | | | | Previous patch f0039aa2a4367df95bda1b6cf3d4a735cafb4eb2 is not correct as it try to fix a bug introduced in commit 3a10216dd01c8d10df235b88c8942b2fda15689b
* Fix a crash in menu codeChristian Persch2010-10-041-1/+1
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=631311
* Make GdkRectangle arguments in GtkCellRenderer use const consistentlyMatthias Clasen2010-10-049-104/+104
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=630900
* quartz: Emulate root window as 1x1 bitmapKristian Rietveld2010-10-044-21/+138
| | | | | | | We subclass GdkWindowImplQuartz into a new GdkRootWindowImplQuartz, and override the get_context method in order to do this cleanly. Also made release_context a virtual method, since the root window has to release its CGContextRef differently compared to normal windows.
* docs: Move documentation to inline comments: colorsJavier Jardón2010-10-044-188/+21
|
* docs: Move documentation to inline comments: pixbufsJavier Jardón2010-10-043-102/+11
|
* docs: Move documentation to inline comments: regionsJavier Jardón2010-10-044-72/+35
|
* docs: Move documentation to inline comments: cairo_interactionJavier Jardón2010-10-043-99/+18
|
* docs: Move documentation to inline comments: GtkComboBoxJavier Jardón2010-10-044-464/+34
|
* Add missing vfuncs to gtknotebook.Ignacio Casal Quinteiro2010-10-032-12/+34
|
* docs: Move documentation to inline comments: GtkNotebookJavier Jardón2010-10-034-710/+71
|
* Updated Lithuanian translation by Aurimas Černius <aurisc4@gmail.com> and ↵Žygimantas Beručka2010-10-031-2498/+2372
| | | | Rimas Kudelis <rq@akl.lt>
* Updated Lithuanian translation by Aurimas Černius <aurisc4@gmail.com>Žygimantas Beručka2010-10-031-1081/+1109
|
* textview: Fix clip usageJosé Aliste2010-10-031-3/+4
| | | | | | | The previous code used cairo_clip_extents() and interpreted its parameters wrong. https://bugzilla.gnome.org/show_bug.cgi?id=631203
* docs: Latest 2.x release will be 2.24, not 2.22Javier Jardón2010-10-031-3/+3
|
* docs: Use gtk_widget_get_preferred_size() instead ↵Javier Jardón2010-10-035-5/+4
| | | | | | gtk_size_request_get_preferred_size() GtkSizeRequest interface is now merged in GtkWidget
* docs: Move documentation to inline comments: GtkEntryBufferGarrett Regier2010-10-032-171/+1
| | | | | | Fixes https://bugzilla.gnome.org/show_bug.cgi?id=617320 Signed-off-by: Javier Jardón <jjardon@gnome.org>
* docs: Move documentation to inline comments: GtkTooltipJavier Jardón2010-10-033-173/+67
|
* docs: Move documentation to inline comments: GtkToolbarJavier Jardón2010-10-033-305/+24
|
* docs: Move documentation to inline comments: GtkComboBoxEntryGarrett Regier2010-10-023-123/+43
| | | | | | Fixes https://bugzilla.gnome.org/show_bug.cgi?id=617308 Signed-off-by: Javier Jardón <jjardon@gnome.org>
* gail: use a weak pointer instead of an invalid destroy signalWilliam Jon McCann2010-10-021-19/+5
|
* Bump version to 2.91.1Matthias Clasen2010-10-011-1/+1
|
* Fix a reference in the gdk_pixbuf_get_from_surface docs2.91.0Matthias Clasen2010-10-011-1/+1
|
* More distcheck fixesMatthias Clasen2010-10-011-1/+1
|
* gail: Fix menu emission hooksBenjamin Otte2010-10-021-0/+17
| | | | | | Ref the GtkmenuItem class, so we can add emission hooks. And actually add the emission hooks again that were removed in 7c140feb6b18c6e158b83356370a85864758c4f9.
* gdk: Make gdk_pixbuf_get_from_*() bindableBenjamin Otte2010-10-027-101/+36
| | | | | | | | | | The ownership of the return value for gdk_pixbuf_get_from_window() and gdk_pixbuf_get_from_surface() was determined by the first argument. Because that is an ugly design and the functions are new to GTK3, we decided to adapt them. And that adaptation was quite easy since almost no one passses anything but NULL as the first argument.
* Fix distcheckMatthias Clasen2010-10-013-5/+0
| | | | Don't include config.h in headers, it doesn't work.
* Fix make distMatthias Clasen2010-10-011-6/+8
|
* Update NEWS for 2.91.0Matthias Clasen2010-10-011-0/+85
|
* Update po filesMatthias Clasen2010-10-01210-264178/+282759
|
* Distribute autogen.shColin Walters2010-10-011-0/+1
| | | | | | This makes it easier for OS vendors to always invoke autogen.sh for building, regardless of building from legacy tarballs or git snapshots.
* Set version to 2.91.0Matthias Clasen2010-10-011-2/+2
| | | | | Having an odd minor helps some tools which assume 'even minor == stable' and 2.91 will keep us in sync with the wider GNOME versioning.