summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* testsuite: Fix DragContext => Drag renamingwip/otte/dndBenjamin Otte2018-07-142-2/+2
|
* dnd: Add GtkGestureDndDragBenjamin Otte2018-07-144-0/+512
| | | | | This is the replacement for GtkDragSource and the GtkWidget drag source signals.
* gtk: Move GtkGesture declaration to gtktypes.hBenjamin Otte2018-07-142-1/+1
| | | | | That way, headers can use the gesture type without having to include gtkgesture.h
* docs: Remove remains of Mir backendBenjamin Otte2018-07-144-42/+0
|
* textview: Only create cairo context in gtktextdisplay.cBenjamin Otte2018-07-147-116/+99
| | | | | Everything else is done using GtkSnapshot now, including renaming the draw_layer vfunc to snapshot_layer.
* x11: Set BackPixmap = None unconditionallyBenjamin Otte2018-07-141-10/+2
| | | | | | Makes it more obvious what we actually want. Related: #1134
* Update POTFILES.inPiotr Drąg2018-07-132-2/+2
|
* window: Update opaque region if background-color changesBenjamin Otte2018-07-131-2/+15
| | | | | | | | | The opaque region is only set when the background color is opaque. So we need to do something about it when the background color changes. However, in the case where a size allocation is going to happen, we already do this update in size_allocate(), so in that case avoid doing it twice.
* gtk-demo: Update aspect-ratio when selecting new puzzleBenjamin Otte2018-07-131-0/+1
|
* textview: Use snapshot on the sidebarsBenjamin Otte2018-07-131-11/+7
|
* widgetpaintable: Add a hack to make recursion not infloopBenjamin Otte2018-07-133-2/+62
| | | | Makes the GUADEC talk not crash that I'm supposed to give in 20 minutes.
* widgetpaintable: Redo implementationBenjamin Otte2018-07-133-91/+93
| | | | | | | | | | | | | Instead of instantly invalidating, we now cache the old render node and do the update in an idle handler. While that gives us a 1 frame delay, it avoids all the tricky things like queueing resizes while resizing or queueing draws while drawing. The only remaining issue (and a *big* one at that) is that a nested widget paintable will now cause the widget to snapshot its previous render node when creating a new one. And that one will snapshot its previous render node, and that one will... And nothing so far breaks this recursion.
* paintable: Fix return_if_fail() statementsBenjamin Otte2018-07-131-2/+2
| | | | I always switch them up...
* gl: Don't accidentally use ints for float variablesBenjamin Otte2018-07-131-3/+3
| | | | | The int was floor()ing the x/y coordinates of glyphs, which could cause significant repositioning of glyphs when text was scaled via the MVP.
* docs: Small updatesMatthias Clasen2018-07-132-20/+3
| | | | Remove a few references to no-longer-existing APIs.
* Merge branch 'dnd-cleanups' into 'master'Matthias Clasen2018-07-1322-411/+252
|\ | | | | | | | | Dnd cleanups See merge request GNOME/gtk!228
| * dnd: Drop gdk_drag_abortMatthias Clasen2018-07-126-73/+0
| | | | | | | | | | This function is never called, so drop it, its vfunc, and all the backend implementations.
| * dnd: Some documentation updatesMatthias Clasen2018-07-121-6/+9
| | | | | | | | | | Don't mention dnd protocols, and do mention the new, split objects.
| * win32: Build fixesMatthias Clasen2018-07-121-18/+5
| |
| * wayland: Rename a source fileMatthias Clasen2018-07-122-1/+1
| | | | | | | | | | Rename gdkdnd-wayland.c to gdkdrag-wayland.c to go along with gdkdrop-wayland.c.
| * wayland: Drop an unused fieldMatthias Clasen2018-07-121-11/+0
| | | | | | | | | | Nothing was using the foreign_dnd_surface anymore, so no need to create it in the first place.
| * dnd: Drop suggested_actionMatthias Clasen2018-07-124-37/+8
| | | | | | | | | | The only user of this field was the x11 backend, and it turns out that it does not need to store the value at all.
| * drag: Split a setterMatthias Clasen2018-07-123-7/+13
| | | | | | | | | | In preparation for moving the suggested action to the x11 backend, split the setter off.
| * win32: Stop using gdk_drag_get_suggested_actionMatthias Clasen2018-07-121-4/+2
| | | | | | | | | | The suggested action is not set or used in the win32 information, so don't put it in logs either.
| * GdkDrop: drop the priv structMatthias Clasen2018-07-122-77/+48
| | | | | | | | Its not needed.
| * Add a GdkDrag::actions propertyMatthias Clasen2018-07-121-1/+27
| | | | | | | | To go along the GdkDrop::actions property.
| * Rename a propertyMatthias Clasen2018-07-125-19/+20
| | | | | | | | | | | | Change GdkDrag::action to GdkDrag::selected-action, which is more clearly different from actions, and follows the existing name of the struct field and getter.
| * GdkDrag: Drop the priv structMatthias Clasen2018-07-122-53/+33
| | | | | | | | We don't need it.
| * wayland: set a cursor when starting a dragMatthias Clasen2018-07-121-0/+4
| | | | | | | | Otherwise, we wont have one.
| * dnd: Add a GdkDrag::action propertyMatthias Clasen2018-07-125-74/+55
| | | | | | | | | | | | | | This lets us drop the ::action-changed signal for the property change notification. But, can just as well move the signal class handers which just update the cursor to the ::action setter. No need to do this in the backends.
| * wayland: Remove an unused fieldMatthias Clasen2018-07-121-1/+0
| | | | | | | | GdkDragWayland.suggested_action was entirely unused, so drop it.
| * dnd: Rename gtk_drag_begin_with_coordinatesMatthias Clasen2018-07-1211-69/+67
| | | | | | | | | | Now that the coordiate-less variant is gone, rename this back to the shorter gtk_drag_begin.
* | Merge branch 'fix-wayland' into 'master'Matthias Clasen2018-07-120-0/+0
|\ \ | |/ |/| | | | | GtkIMContextSimple: Fix Wayland build when X11 support is disabled See merge request GNOME/gtk!234
| * GtkIMContextSimple: Fix Wayland build when X11 support is disabled.Emmanuel Gil Peyrot2018-07-081-1/+1
| |
* | Merge branch 'master' into 'master'Daniel Boles2018-07-097-12/+35
|\ \ | | | | | | | | | | | | | | | | | | HighContrast: Restore expander size Closes #1046 See merge request GNOME/gtk!167
| * | HighContrast: Restore expander sizeSamuel Thibault2018-06-213-8/+8
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | Expanders used to be 16px high. With the move from the gtk2 rendering to gtk3 rendering they shrunk to 12px, making them hard to see, because it's now the icon which is 16px high and the icon contains transparent borders. This makes the HighContrast theme use 24px icons instead, to restore 16px expanders. This may expander some containers a bit. Closes #1046
| * | TreeView: Get expander size from CSS min-width|heightDaniel Boles2018-06-217-8/+31
| | | | | | | | | | | | | | | | | | | | | Rather than hard-coding this, get it from CSS. That way, themes will be able to set larger expanders than a fixed 16 px, e.g. for accessibility. See https://gitlab.gnome.org/GNOME/gtk/merge_requests/167
* | | widget factory: Use GtkPicture for background selectionTimm Bäder2018-07-081-4/+3
| | | | | | | | | | | | Showing those background images as 16×16 icons doesn't look very nice.
* | | gl renderer: Cache blurred outset shadow nodesTimm Bäder2018-07-084-66/+237
| | | | | | | | | | | | | | | Since these are particularly expensive to render and we have a pretty big one used in every client-side decorated window.
* | | aboutdialog: Remove priv pointerTimm Bäder2018-07-082-102/+83
| | |
* | | layout: Remove priv pointerTimm Bäder2018-07-082-37/+21
| | |
* | | rendernodes: Fix unconditionally impossible diffsTimm Bäder2018-07-081-8/+14
| | | | | | | | | | | | | | | | | | | | | | | | Some of the _diff implementations did a whole bunch of work just to throw it away afterwards and invalidate the entire union of the two render nodes, most notably the two clip nodes. Fix this to only call gsk_render_node_diff_impossible if the previous if-condition is FALSE and not always.
* | | GskRenderer: Add missing nullable annotationTimm Bäder2018-07-081-2/+2
| | |
* | | Revert "snapshot: merge container nodes"Timm Bäder2018-07-081-16/+2
| | | | | | | | | | | | This reverts commit 622a150bb4a83afba909c051a4baf12a88868e62.
* | | Update Hungarian translationBalázs Meskó2018-07-081-1961/+2233
| | |
* | | Implement GtkInspectorLayoutOverlayTimm Bäder2018-07-085-97/+270
| | | | | | | | | | | | To properly replace the old "show layout borders" option.
* | | treeview: Fix column visibility checkTimm Bäder2018-07-081-2/+7
| | | | | | | | | | | | | | | | | | This is still fallout from the bin_window removal. We aren't moving the GdkWindow/GdkSurface anymore so we have to account for the scrolling ourselves.
* | | treeview: Move column header widgets when scrollingTimm Bäder2018-07-081-6/+8
| | | | | | | | | | | | | | | | | | | | | | | | Since those are widgets and widgets need to be size-allocate'd properly, we need to queue an allocate, as well as actually add the hadjustment's value to the column x position. Fixes #1202
* | | aspectframe: Remove priv pointerTimm Bäder2018-07-082-20/+13
| | |
* | | scalebutton: Remove priv pointerTimm Bäder2018-07-082-46/+44
| | |