| Commit message (Collapse) | Author | Age | Files | Lines |
|
|
|
|
|
|
|
| |
Those property features don't seem to be in use anywhere.
They are redundant since the docs cover the same information
and more. They also created unnecessary translation work.
Closes #4904
|
|
|
|
| |
On the magic numbers used to get the abbreviated day names.
|
|
|
|
|
|
|
|
|
|
|
|
| |
... if the current locale has a different starting day than Sunday.
This needed 2 fixes:
* We need to take into account `calendar->week_start` when
creating/adding the appropriate `day_name_labels` field
* we were only calculating `calendar->week_start` _after_ attaching the
`day_name_labels`, so it was still set to 0 (the default value).
Fixes https://gitlab.gnome.org/GNOME/gtk/-/issues/4338
|
|
|
|
| |
Replace leftover gtk-doc syntax (#Type) with backquotes.
|
|
|
|
|
| |
Mostly fixing up indentation of continuation lines,
and other small cleanups.
|
|
|
|
|
| |
We no longer unselect the current day when 0 is set, so update the
documentation and the property definition.
|
|
|
|
|
| |
The day is a number between 1 and 31 and that's what we get from
GDateTime.
|
| |
|
| |
|
|
|
|
| |
Connect properties, getters, and setters with annotations.
|
|
|
|
| |
Change link syntax, add an example image, generally clean things up.
|
|
|
|
|
|
| |
Remove some unnecessary uses of GtkStyleContext where
we can directly go to the GtkCssStyle, and and drop
unnnecessary includes.
|
|
|
|
|
|
| |
We document the supported style classes by name,
not by macro name, and these macros don't really
add any value. Drop them for GTK 4.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
To build a better world sometimes means having to tear the old one down.
-- Alexander Pierce, "Captain America: The Winter Soldier"
ATK served us well for nearly 20 years, but the world has changed, and
GTK has changed with it. Now ATK is mostly a hindrance towards improving
the accessibility stack:
- it maps to a very specific implementation, AT-SPI, which is Linux and
Unix specific
- it requires implementing the same functionality in three different
layers of the stack: AT-SPI, ATK, and GTK
- only GTK uses it; every other Linux and Unix toolkit and application
talks to AT-SPI directly, including assistive technologies
Sadly, we cannot incrementally port GTK to a new accessibility stack;
since ATK insulates us entirely from the underlying implementation, we
cannot replace it piecemeal. Instead, we're going to remove everything
and then incrementally build on a clean slate:
- add an "accessible" interface, implemented by GTK objects directly,
which describe the accessible role and state changes for every UI
element
- add an "assistive technology context" to proxy a native accessibility
API, and assign it to every widget
- implement the AT context depending on the platform
For more information, see: https://gitlab.gnome.org/GNOME/gtk/-/issues/2833
|
| |
|
| |
|
| |
|
|
|
|
| |
These are all on GtkBox or enumerating children.
|
|
|
|
|
| |
In many cases, the default widget vfuncs work just fine,
combined with setting focusable.
|
|
|
|
|
|
|
|
|
|
| |
Add back a property that determines whether an individual
widget will accept focus or not. :can-focus prevents the
focus from ever entering the entire widget hierarchy
below a widget, and :focusable just determines if grabbing
the focus to the widget itself will succeed.
See #2686
|
| |
|
| |
|
|
|
|
| |
This broke when the calendar was broken into widgets.
|
|
|
|
|
|
|
|
| |
After the :can-focus change in the previous commit, widgets
need to set suitable focus and grab_focus implementations
to implement the desired focus behavior.
This commit does that for all widgets.
|
|
|
|
| |
Fixes #2490
|
| |
|
| |
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
This is a huge reorganization of GtkDropTarget. I did not know how to
split this up, so it's unfortunately all one commit.
Highlights:
- Split GtkDropTarget into GtkDropTarget and GtkDropTargetAsync
GtkDropTarget is the simple one that only works with GTypes and offers
a synchronous interface.
GtkDropTargetAsync retains the full old functionality and allows
handling mime types.
- Drop events are handled differently
Instead of picking a single drop target and sending all DND events to
it, every event is sent to every drop target. The first one to handle
the event gets to call gdk_drop_status(), further handlers do not
interact with the GdkDrop.
Of course, for the ultimate GDK_DROP_STARTING event, only the first
one to accept the drop gets to handle it.
This allows stacking DND event controllers that aren't necessarily
interested in handling the event or that might decide later to drop
it.
- Port all widgets to either of those
Both have a somewhat changed API due to the new event handling.
For the ones who should use the sync version, lots of cleanup was
involved to operate on a sync API.
|
|
|
|
| |
Those are all forgotten transitions while updating code to new APIs.
|
|
|
|
|
|
|
|
| |
Split the focus tracking into a separate
GtkEventControllerFocus, and change the API one more time.
We are back to having ::focus-in and ::focus-out signals.
Update all users.
|
|
|
|
|
|
|
|
|
|
|
|
|
|
| |
Instead of relying on gdk's antiquated crossing events,
create a new GtkCrossingData struct that contains the
actual widgets, and a new event controller vfunc that
expects this struct. This also saves us from making sense
of X's crossing modes and details, and makes for a
generally simpler api.
The ::focus-in and ::focus-out signals of GtkEventControllerKey
have been replaced by a single ::focus-change signal that
takes GtkCrossingData as an argument. All callers have
been updated.
|
|
|
|
| |
Saves tons of code.
|
|
|
|
|
| |
Gets around the boilerplate required to create and initialize a GValue
by having this function doing it via G_VALUE_COLLECT().
|
|
|
|
| |
Fixes #833
|
|
|
|
|
|
| |
Add the .today style class to the label indicating the current day.
Fixes #230
|
|
|
|
| |
Fixes #790
|
| |
|
|
|
|
|
| |
GDatetime uses 1-based month and day numbers, whereas
GktCalendars are 0-based. Correct for this.
|
|
|
|
| |
Our a11y tests were relying on this.
|
|
|
|
| |
We want to use css instead of style everywhere now.
|
|
|
|
|
|
| |
It doesn't really make sense to treat double clicks here different than
single clicks (and is bad UX), and it also breaks switching months by
quickly trying to single-click the last/first days in the calendar.
|
| |
|
|
|
|
| |
Listen to notify::month instead.
|
|
|
|
| |
Instead of a year/month/day triple.
|
| |
|
| |
|
| |
|
| |
|
|
|
|
| |
This is dead code
|
|
|
|
|
| |
Instead of having a display flags enum and bitfield, just add proper
accessors for the properties, which is what we do everywhere else.
|