summaryrefslogtreecommitdiff
path: root/gtk/gtkpopovermenubar.c
Commit message (Collapse)AuthorAgeFilesLines
* Remove all nicks and blurbs from param specsSophie Herold2022-05-111-3/+1
| | | | | | | | Those property features don't seem to be in use anywhere. They are redundant since the docs cover the same information and more. They also created unnecessary translation work. Closes #4904
* gtk: add nullable annotations to PopoverMenuBar/PopoverMenuBilal Elmoussaoui2022-01-011-1/+1
| | | | The constructor/setter accepts a null as a model so should the getter
* popovermenubar: Make submenu-actions workMatthias Clasen2021-06-051-45/+45
| | | | | We were not updating submenu-action state for items in menubars.
* gtk: Clean up docs syntaxMatthias Clasen2021-05-221-1/+1
| | | | Replace leftover gtk-doc syntax (#Type) with backquotes.
* docs: Reduce redundancyMatthias Clasen2021-05-201-2/+2
| | | | | | | | Remove a boatload of "or %NULL" from nullable parameters and return values. gi-docgen generates suitable text from the annotation that we don't need to duplicate. This adds a few missing nullable annotations too.
* introspection: Stop using allow-noneMatthias Clasen2021-05-201-2/+2
| | | | | allow-none has been deprecated for a long time already. Instead use optional and nullable everywhere.
* popovermenubar: Use markdown for css treeMatthias Clasen2021-03-111-2/+2
|
* popovermenubar: Convert docsMatthias Clasen2021-03-111-26/+24
|
* Merge branch 'wip/surface-state-rework' into 'master'Matthias Clasen2020-12-081-1/+1
|\ | | | | | | | | Rework surface state and geometry computation See merge request GNOME/gtk!2885
| * gtk/popover: Use gtk_popover_present() instead of going via GtkNativeJonas Ådahl2020-12-071-1/+1
| | | | | | | | This makes it more explicit that managers of popovers make it "present".
* | Use function setter for WidgetClass.activate_signalEmmanuele Bassi2020-12-051-1/+3
|/
* a11y: Parse reference lists using varargsEmmanuele Bassi2020-11-101-2/+2
| | | | | | | | | | Using GList is a bit lame, and makes the API more complicated to use than necessary in the common case. The only real use case for a GList is gtk_widget_add_mnemonic_label(), and for that we can use the GValue-based API instead. Fixes: #3343
* popovermenu: Allow adding custom items in ui filesMatthias Clasen2020-10-261-1/+31
| | | | | | Support <child type="ID"> to fill custom child slots in both GtkPopoverMenus and GtkPopoverMenuBars that are created in ui files.
* popovermenu: Allow custom itemsMatthias Clasen2020-10-261-0/+70
| | | | | | | | | | | | | | Add a way to add children at certain places in the generated menu for both GtkPopoverMenu and GtkPopoverMenuBar. New apis: gtk_popover_menu_add_child gtk_popover_menu_remove_child gtk_popover_menu_bar_add_child gtk_popover_menu_bar_remove_child Fixes: #3260
* popovermenubar: Initial accessibility setupMatthias Clasen2020-10-211-2/+41
| | | | | | Set roles, properties and relations according to the ARIA authoring practices document. This is not quite complete.
* Remove unneeded gtkstylecontext.h includesTimm Bäder2020-10-141-1/+0
|
* Replace "gint" with "int"Benjamin Otte2020-07-251-2/+2
|
* eventcontrollermotion: Remove mode argumentBenjamin Otte2020-05-301-2/+0
| | | | It's not used and nobody has documented how it's meant to work anyway.
* widget: Add a :focusable propertyMatthias Clasen2020-05-101-1/+1
| | | | | | | | | | Add back a property that determines whether an individual widget will accept focus or not. :can-focus prevents the focus from ever entering the entire widget hierarchy below a widget, and :focusable just determines if grabbing the focus to the widget itself will succeed. See #2686
* popovermenubar: Avoid calling gtk_widget_destroy()Timm Bäder2020-02-251-3/+3
|
* popover: Drop ::relative-toMatthias Clasen2020-02-241-1/+2
| | | | | | | | | It is enough to just set the parent (and make the parent call gtk_native_check_resize in size_allocate). This commit removes the relative_to argument to the constructors of GtkPopover and GtkPopoverMenu, and updates all callers.
* Go back to ::enter/::leave for pointer changesMatthias Clasen2020-02-211-22/+14
| | | | | These signals are behaving a little differently from what ::focus-in/::focus-out used to do.
* Make crossing events handled the same wayMatthias Clasen2020-02-211-18/+22
|
* docs: Rewrite popover menu docsMatthias Clasen2019-12-291-5/+6
| | | | These were outdated and did not reflect current api.
* window: Move F10 handling to popover menubarsMatthias Clasen2019-12-291-1/+96
|
* popovermenubar: CosmeticsMatthias Clasen2019-12-291-3/+2
|
* Privatize popover menu piecesMatthias Clasen2019-11-111-12/+15
| | | | | | Don't allow manual creation of popover menus anymore. This lets us also make GtkModelButton private
* popover menubar: Use nested popover menusMatthias Clasen2019-09-081-1/+1
| | | | | | Make the popover menubar use nested menus, to better match the expected behavior of traditional menus.
* Add nesting popover menusMatthias Clasen2019-09-081-1/+5
| | | | | | Add a variant of popover menus that are nesting like traditional menus. This is a better fit for replacing traditional main menus.
* popover menubar: Use a pseudo stateMatthias Clasen2019-06-121-11/+3
| | | | | Use :selected instead of .active to mark the active item.
* popover menu bar: Don't leave active item behindMatthias Clasen2019-06-121-0/+24
| | | | When the mouse leaves the bar, turn the lights off.
* Rename a bunch of private headersMatthias Clasen2019-06-101-1/+1
| | | | | We want to follow the convention that all private headers have names ending in private.h
* popovermenubar: Add docsMatthias Clasen2019-06-091-0/+53
|
* Rename GtkPopoverBar to GtkPopoverMenuBarMatthias Clasen2019-06-091-0/+531
Clarity over beauty.