summaryrefslogtreecommitdiff
path: root/buildsystems/autotools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'buildsystems/autotools/meson.build')
-rw-r--r--buildsystems/autotools/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/buildsystems/autotools/meson.build b/buildsystems/autotools/meson.build
new file mode 100644
index 0000000..6a8b1cc
--- /dev/null
+++ b/buildsystems/autotools/meson.build
@@ -0,0 +1,28 @@
+custom_target(
+ 'gtk-doc.flat.make',
+ input: 'gtk-doc.make',
+ output: 'gtk-doc.flat.make',
+ install: true,
+ install_dir: pkgdatadir,
+ capture: true,
+ command: [
+ 'sed',
+ '-e',
+ 's/EXTRA_DIST =/EXTRA_DIST +=/',
+ '@INPUT@',
+ ]
+)
+
+custom_target(
+ 'gtk-doc.m4',
+ input: 'gtk-doc.m4',
+ output: 'gtk-doc.m4',
+ install: true,
+ install_dir: autoconfdatadir,
+ command: [
+ 'cp',
+ '-f',
+ '@INPUT@',
+ '@OUTPUT@',
+ ],
+)