summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2010-03-16 21:37:12 +0100
committerAndy Wingo <wingo@pobox.com>2010-03-16 21:44:34 +0100
commit718815d7618fe7766f3620538917849ccc93f36f (patch)
tree4ff3f7f3d0eb7a2390a8909200aab472d2afb67b /Makefile.am
parent44602b08680ad6422dd88780c23540c0632bcc68 (diff)
downloadguile-718815d7618fe7766f3620538917849ccc93f36f.tar.gz
parallel installability for libguile*.h
* Makefile.am: * libguile/Makefile.am (modincludedir): Install into $pkgincludedir/$GUILE_EFFECTIVE_VERSION. This allows multiple Guile development packages to be installed at once. * guile-readline/Makefile.am (modincludedir): * srfi/Makefile.am (srfiincludedir): Likewise. * meta/guile-2.0.pc.in (Cflags): Add the appropriate -I line so that user code picks up the new location transparently.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 20f03826a..bbd135284 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,6 @@
## Process this file with automake to produce Makefile.in.
##
-## Copyright (C) 1998, 1999, 2000, 2001, 2002, 2006, 2007, 2008, 2009 Free Software Foundation, Inc.
+## Copyright (C) 1998, 1999, 2000, 2001, 2002, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
##
## This file is part of GUILE.
##
@@ -28,7 +28,8 @@ SUBDIRS = lib meta libguile guile-readline emacs \
srfi examples test-suite benchmark-suite am \
module doc testsuite
-include_HEADERS = libguile.h
+libguileincludedir = $(pkgincludedir)/$(GUILE_EFFECTIVE_VERSION)
+libguileinclude_HEADERS = libguile.h
EXTRA_DIST = LICENSE HACKING GUILE-VERSION \
m4/ChangeLog-2008 \