summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2009-03-27 14:03:03 -0700
committerAndy Wingo <wingo@pobox.com>2009-03-27 14:03:03 -0700
commit0b6d8fdc28ed8af56e93157179c305fef037e0a0 (patch)
treeef27c6f315e1f289639bc2febba5907bb313401a /Makefile.am
parent0fe95f9c4ce063781e79a15bc123c57c33ef9755 (diff)
downloadguile-0b6d8fdc28ed8af56e93157179c305fef037e0a0.tar.gz
allow building against uninstalled guile; move some things to meta/
* README: Add more info about building against an uninstalled Guile. * meta/: New directory. The proximate cause of its creation is that I want to be able to build external packages against uninstalled Guile, and to do that I need guile-tools in the PATH, but I don't want $top_builddir/libtool in the path. But it seems like a good reorganization, for things that are /about/ Guile: pkg-config files, m4 files, guile-config... then we also include uninstalled info: the environment, the pre-inst-guile script, etc. * meta/guile-1.8-uninstalled.pc.in: New pkg-config template. pkg-config prefers -uninstalled pkg-config files, if they are in its path. * meta/Makefile.am: * meta/ChangeLog-2008: * meta/gdb-uninstalled-guile.in: * meta/guile-1.8.pc.in: * meta/guile-config.in: * meta/guile.m4: * meta/guile-tools.in: Moved to meta/. * meta/guile.in: This is the new name of pre-inst-guile.in. * meta/uninstalled-env.in: And this, pre-inst-guile-env.in. * Makefile.am: * am/guilec: * am/pre-inst-guile: * check-guile.in: * configure.in: * doc/ref/Makefile.am: * gc-benchmarks/run-benchmark.scm: * test-suite/standalone/Makefile.am: * test-suite/standalone/README: * testsuite/Makefile.am: Adapt to meta/ change.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 556b32141..0e61f531d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,16 +24,14 @@
#
AUTOMAKE_OPTIONS = 1.10
-SUBDIRS = lib libguile guile-config guile-readline emacs \
+SUBDIRS = lib meta libguile guile-readline emacs \
scripts srfi doc examples test-suite benchmark-suite lang am \
module testsuite
-bin_SCRIPTS = guile-tools
-
include_HEADERS = libguile.h
EXTRA_DIST = LICENSE HACKING GUILE-VERSION \
- m4/ChangeLog-2008 FAQ guile-1.8.pc.in \
+ m4/ChangeLog-2008 FAQ \
m4/autobuild.m4 ChangeLog-2008
TESTS = check-guile
@@ -42,7 +40,4 @@ ACLOCAL_AMFLAGS = -I m4
DISTCLEANFILES = check-guile.log
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = guile-1.8.pc
-
# Makefile.am ends here