summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2010-11-19 11:39:06 +0100
committerAndy Wingo <wingo@pobox.com>2010-11-19 15:22:43 +0100
commit8d4f5e8f92b8f0effead923648b274554f54e4df (patch)
treeabaa005ecdef99614ca01ba204ed35d90df8a18b /configure.ac
parente25f37271acde5b9e3c34420ad9d0faa62b7503d (diff)
downloadguile-8d4f5e8f92b8f0effead923648b274554f54e4df.tar.gz
relax sizeof(long) restriction in configure.ac
* configure.ac: Relax the sizeof(long)==sizeof(void*) restriction, instead asserting that the sizeof(long)<=sizeof(void*). There will still be problems on nonstandard platforms related to the interface with gmp, but those are confined to numbers.c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4b4323f73..344699227 100644
--- a/configure.ac
+++ b/configure.ac
@@ -281,8 +281,8 @@ AC_CHECK_SIZEOF(ptrdiff_t)
AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(off_t)
-if test "$ac_cv_sizeof_long" -ne "$ac_cv_sizeof_void_p"; then
- AC_MSG_ERROR(sizes of long and void* are not identical)
+if test "$ac_cv_sizeof_long" -gt "$ac_cv_sizeof_void_p"; then
+ AC_MSG_ERROR(long does not fit into a void*)
fi
if test "$ac_cv_sizeof_ptrdiff_t" -ne 0; then