summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndy Wingo <wingo@pobox.com>2021-03-07 20:43:16 +0100
committerAndy Wingo <wingo@pobox.com>2021-03-07 20:43:16 +0100
commit91547abf54d5e0795afda2781259ab8923eb527b (patch)
tree5849043a68ce7f48d7d9c0a88d18f3b588a00cfe /configure.ac
parentcad6094cbc15e78bce2384a5af754bc841ca9127 (diff)
downloadguile-91547abf54d5e0795afda2781259ab8923eb527b.tar.gz
More informative error message if GMP not found
* configure.ac: Mention --enable-mini-gmp if GMP not found.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index a3cdaff78..b33777104 100644
--- a/configure.ac
+++ b/configure.ac
@@ -657,7 +657,7 @@ if test "x$enable_mini_gmp" = xyes || test "x$enable_mini_gmp" = xy; then
else
AC_LIB_HAVE_LINKFLAGS([gmp],[],[#include <gmp.h>], [mpz_import (0,0,0,0,0,0,0);])
if test "x$HAVE_LIBGMP" != "xyes"; then
- AC_MSG_ERROR([GNU MP 4.1 or greater not found])
+ AC_MSG_ERROR([GNU MP 4.1 or greater not found; either install it, or pass '--enable-mini-gmp' to use included less-optimal arbitrary-precision integer support.])
fi
if test "x$LIBGMP_PREFIX" != "x"; then
CPPFLAGS="-I$LIBGMP_PREFIX $CPPFLAGS"