summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2011-01-31 19:26:01 +0100
committerLudovic Courtès <ludo@gnu.org>2011-01-31 19:26:01 +0100
commit2ddf08514965cb7c0fa60a56b343dfa811e836e5 (patch)
treeba93581df6d5b2f34824725c51f8172389caa3b2 /configure.ac
parenta8591a55f0d7186fbdd58b3c570bbe945b58fa11 (diff)
downloadguile-2ddf08514965cb7c0fa60a56b343dfa811e836e5.tar.gz
Disable stand-alone tests that require `dlopen' when `--disable-shared'.
* configure.ac (HAVE_SHARED_LIBRARIES): New Automake conditional. * test-suite/standalone/Makefile.am (check_SCRIPTS): Add `test-asmobs', `test-ffi', and `test-extensions' only when `HAVE_SHARED_LIBRARIES'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 5c70aa8b0..69f35e278 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,8 @@ dnl
define(GUILE_CONFIGURE_COPYRIGHT,[[
-Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
+Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, 2006,
+ 2007, 2008, 2009, 2010, 2011 Free Software Foundation, Inc.
This file is part of GUILE
@@ -75,6 +76,8 @@ AM_PROG_CC_C_O
AC_LIBTOOL_DLOPEN
AC_PROG_LIBTOOL
+AM_CONDITIONAL([HAVE_SHARED_LIBRARIES], [test "x$enable_shared" = "xyes"])
+
dnl Check for libltdl.
AC_LIB_HAVE_LINKFLAGS([ltdl], [], [#include <ltdl.h>],
[lt_dlopenext ("foo");])