summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNoah Lavine <nlavine@haverford.edu>2011-02-13 15:31:32 -0500
committerAndy Wingo <wingo@pobox.com>2011-02-13 22:08:44 +0100
commit482d311b3945a2b7133888b18f1fd18e472f8ce8 (patch)
treeca67080bc2d4322c15e75b77edabd2da4adfc43a /configure.ac
parente8ab529d57e2c3820e567737bd53c6e05e484c4d (diff)
downloadguile-482d311b3945a2b7133888b18f1fd18e472f8ce8.tar.gz
Set sockaddr_in.sin_len field when it exists.
* configure.ac: Detect when struct sockaddr_in has a sin_len field. Remove obsolete comment. * libguile/socket.c (scm_to_sockaddr, scm_fill_sockaddr): Set the sin_len field in our struct sockaddr_in when it exists.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index fd5067274..5b47701b7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -957,10 +957,7 @@ AC_CHECK_FUNCS(sethostent gethostent endhostent dnl
getnetbyaddr getnetbyname dnl
inet_lnaof inet_makeaddr inet_netof hstrerror)
-# struct sockaddr field sin_len is only present on BSD systems.
-# On 4.4BSD apparently a #define SIN_LEN exists, but on other BSD systems
-# (eg. FreeBSD 4.9) it doesn't and we must use this configure check
-AC_CHECK_MEMBERS([struct sockaddr.sin_len],,,
+AC_CHECK_MEMBERS([struct sockaddr_in.sin_len],,,
[#ifdef HAVE_SYS_TYPES_H
#include <sys/types.h>
#endif