summaryrefslogtreecommitdiff
path: root/libguile/Makefile.am
diff options
context:
space:
mode:
authorGreg J. Badros <gjb@cs.washington.edu>1999-12-12 23:37:40 +0000
committerGreg J. Badros <gjb@cs.washington.edu>1999-12-12 23:37:40 +0000
commit3dc81fbacea7ccac0e9f1a1f97f93ed7d2e00aba (patch)
tree858747dd8b54b11a54c3f0aab8368653a26f2ad9 /libguile/Makefile.am
parent66c24ad36ac680c72b67050d16f6fd7549969265 (diff)
downloadguile-3dc81fbacea7ccac0e9f1a1f97f93ed7d2e00aba.tar.gz
* snarf.h: Drop SCM_PROC, SCM_PROC1. Added extra output for
guile-doc-snarf script. * guile-doc-snarf.in, guile-doc-snarf.awk: New, simple doc extraction system. Builds foo.x, foo.doc from foo.{c,cc}. There are dependencies between these files and snarf.h. This replaces guile-snarf. * guile-snarf.in: Drop everything after $$$ for the new snarf.h macros. This is obsoleted by guile-doc-snarf, but kept here for now for good measure. * Makefile.am: Added guile-doc-snarf, guile-doc-snarf.awk to bin_SCRIPTS. Added .doc to SUFFIXES, and give rule for creating .doc files to use guile-doc-snarf. Update the rule for creating .x files to use guile-doc-snarf.
Diffstat (limited to 'libguile/Makefile.am')
-rw-r--r--libguile/Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/libguile/Makefile.am b/libguile/Makefile.am
index 0e95e1df0..aa980b026 100644
--- a/libguile/Makefile.am
+++ b/libguile/Makefile.am
@@ -103,7 +103,7 @@ modinclude_HEADERS = \
## and not a header -- headers are included in the distribution.
modinclude_DATA = scmconfig.h
-bin_SCRIPTS = guile-snarf
+bin_SCRIPTS = guile-snarf guile-doc-snarf guile-doc-snarf.awk
check_ldadd = libguile.la ${THREAD_LIBS_LOCAL}
check_PROGRAMS = gh_test_c gh_test_repl
@@ -154,10 +154,16 @@ libpath.h: $(srcdir)/Makefile.in $(top_builddir)/config.status
@echo '}' >> libpath.tmp
@mv libpath.tmp libpath.h
-SUFFIXES = .x
+
+# ./guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< > $@
+
+SUFFIXES = .x .doc
.c.x:
- ./guile-snarf $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< > $@ \
+ ./guile-doc-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< \
|| { rm $@; false; }
+.c.doc:
+ ./guile-doc-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< \
+ || { rm $@; false; }
## Add -MG to make the .x magic work with auto-dep code.
MKDEP = gcc -M -MG $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS)