summaryrefslogtreecommitdiff
path: root/libguile/Makefile.am
diff options
context:
space:
mode:
authorGreg J. Badros <gjb@cs.washington.edu>1999-12-14 17:41:59 +0000
committerGreg J. Badros <gjb@cs.washington.edu>1999-12-14 17:41:59 +0000
commite8e9b690b4f0394f958e0613bc2a4d5e8c524518 (patch)
tree9368d40ade081bf917992e8f6092cc6d95104963 /libguile/Makefile.am
parent5623a9b4590618773e7969b512850cd92bfd79ed (diff)
downloadguile-e8e9b690b4f0394f958e0613bc2a4d5e8c524518.tar.gz
* backtrace.c (scm_set_print_params_x): Renamed from
set_print_params_x. * guile-doc-snarf.in: Use guile-snarf.awk, not guile-doc-snarf.awk. Pass the basename of $filename * load.h: Added prototypes for scm_sys_library_dir, scm_sys_site_dir. * load.c (scm_sys_library_dir, scm_sys_site_dir): Added these functions, and took out the old scm_library_dir, scm_site_dir, scm_pkgdata_dir. Now the primitives are %package-data-dir (already existed), %library-dir, and %site-dir. * debug.c: Use SCM_MISC_ERROR when possible instead of using s_scm_* in a scm_misc_error() call. * Makefile.am: Use guile-snarf.awk, not guile-doc-snarf.awk. Make using guile-doc-snarf send stdout to $@ to create the .x file like guile-snarf does. * guile-snarf.awk.in: Added.
Diffstat (limited to 'libguile/Makefile.am')
-rw-r--r--libguile/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libguile/Makefile.am b/libguile/Makefile.am
index 1297330be..85b401fe4 100644
--- a/libguile/Makefile.am
+++ b/libguile/Makefile.am
@@ -104,7 +104,7 @@ modinclude_HEADERS = \
## and not a header -- headers are included in the distribution.
modinclude_DATA = scmconfig.h
-bin_SCRIPTS = guile-snarf guile-doc-snarf guile-doc-snarf.awk
+bin_SCRIPTS = guile-snarf guile-doc-snarf guile-snarf.awk
check_ldadd = libguile.la ${THREAD_LIBS_LOCAL}
check_PROGRAMS = gh_test_c gh_test_repl
@@ -160,7 +160,7 @@ libpath.h: $(srcdir)/Makefile.in $(top_builddir)/config.status
SUFFIXES = .x .doc
.c.x:
- ./guile-doc-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< \
+ ./guile-doc-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< > $@ \
|| { rm $@; false; }
.c.doc:
./guile-doc-snarf $< $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $< \