summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRichard Hughes <richard@hughsie.com>2021-05-21 11:08:47 +0100
committerRichard Hughes <richard@hughsie.com>2021-05-21 11:08:47 +0100
commite733d343943a632585d9e8dcfa143bc5d9bd2568 (patch)
tree688733e27b555b474415f665e231f0d9bd57dca4 /meson.build
parentbd503d0b989d57e038435585eba3963c2d4e4588 (diff)
downloadgusb-e733d343943a632585d9e8dcfa143bc5d9bd2568.tar.gz
Do not depend on libusb_get_port_number() to fix DragonFlyBSD compile
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 128ad6e..3f50b7c 100644
--- a/meson.build
+++ b/meson.build
@@ -107,6 +107,9 @@ endif
if cc.has_header_symbol('libusb-1.0/libusb.h', 'libusb_get_parent')
conf.set('HAVE_LIBUSB_GET_PARENT', '1')
endif
+if cc.has_header_symbol('libusb-1.0/libusb.h', 'libusb_get_port_number')
+ conf.set('HAVE_LIBUSB_GET_PORT_NUMBER', '1')
+endif
gusb_deps = [
libgio,