summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChristian Kellner <gicmo@gnome.org>2010-02-15 12:37:32 +0100
committerChristian Kellner <gicmo@gnome.org>2010-02-15 12:37:32 +0100
commitf7634738ef201deefec1148ef98ee94b6456633c (patch)
treec05b9dbf39e4bdac89da74fc6818a132e50fbb08 /Makefile.am
parent52ab4355f74a0862815ce2d29a6388830c2cb244 (diff)
downloadgvfs-f7634738ef201deefec1148ef98ee94b6456633c.tar.gz
Call gio-querymodules only when DESTDIR is not set
This is a bug introduced in a18a1896c0bceaf9a467f00a9678e322d615e786. We want to call gio-querymodules on install, except when building a package. Based on a patch from Vincent Untz <vuntz@gnome.org>. Fixes #609927.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4dde3381..95d06549 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,8 +33,8 @@ distclean-local:
fi
install-data-hook:
- if test ! -z "$(DESTDIR)" -a "$(GIO_QUERYMODULES)" != "no" ; then \
- $(GIO_QUERYMODULES) $(DESTDIR)$(giomodulesdir) ; \
+ if test -z "$(DESTDIR)" -a "$(GIO_QUERYMODULES)" != "no" ; then \
+ $(GIO_QUERYMODULES) $(giomodulesdir) ; \
fi
uninstall-local: