summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2010-01-12 16:35:16 +0100
committerAlexander Larsson <alexl@redhat.com>2010-01-12 16:35:16 +0100
commit64cc7ebda2a7d5ecaf88a135182a27874bf83e5d (patch)
treee96eb695ad7e32ce5ed91e05a75ccdc2cf3c2c6f /Makefile.am
parent438628c6794fc8f9203fbd99b534371a1aa6d11a (diff)
downloadgvfs-64cc7ebda2a7d5ecaf88a135182a27874bf83e5d.tar.gz
Enable support for lazy loading of gio modules
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d996b8d9..c85c8718 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,6 +32,14 @@ distclean-local:
rm -f ChangeLog; \
fi
+install-data-hook:
+ if test -z "$(DESTDIR)" ; then \
+ $(GIO_QUERYMODULES) $(DESTDIR)$(giomodulesdir) ; \
+ fi
+
+uninstall-local:
+ $(RM) $(DESTDIR)$(GIO_MODULE_DIR)/giomodules.cache
+
ChangeLog:
$(AM_V_GEN) if test -d "$(srcdir)/.git"; then \
(GIT_DIR=$(top_srcdir)/.git ./missing --run git log GVFS_1_2_2.. --stat -M -C --name-status --date=short --no-color) | fmt --split-only > $@.tmp \