summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2009-04-17 11:23:13 +0200
committerAlexander Larsson <alexl@redhat.com>2009-04-17 11:23:13 +0200
commita8620dfb94955fd9e6678dc936b7f97d8610df00 (patch)
treeb9d7df0c35bfe5a43ef0bfa43895ebe7e8095235 /Makefile.am
parentcd9a1633a35b1243805c0e531a1f7bd75160a7d4 (diff)
downloadgvfs-a8620dfb94955fd9e6678dc936b7f97d8610df00.tar.gz
Add rules to autogenerate ChangeLog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f7c5bf6f..b47d4a93 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,3 +25,24 @@ DISTCLEANFILES = \
intltool-merge \
intltool-update \
$(NULL)
+
+distclean-local:
+ if test $(srdcir) = .; then :; else \
+ rm -f ChangeLog; \
+ fi
+
+ChangeLog:
+ @echo Creating $@
+ @if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git ./missing --run git log GVFS_1_2_2.. --stat -M -C --name-status --date=short --no-color) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog