summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@redhat.com>2007-10-08 14:48:28 +0000
committerAlexander Larsson <alexl@src.gnome.org>2007-10-08 14:48:28 +0000
commit6f6ab7302de0257589be2e6c3c9b93a581694a88 (patch)
treea864f6d0d5cd2ca0ea8e01d2cea87b4995fb2ea6 /client/Makefile.am
parent52e63ca2a3371cbaf24d8189ec80abd24dc0fd99 (diff)
downloadgvfs-6f6ab7302de0257589be2e6c3c9b93a581694a88.tar.gz
Add defines for monitoring
2007-10-08 Alexander Larsson <alexl@redhat.com> * common/gvfsdaemonprotocol.h: Add defines for monitoring * client/Makefile.am: * client/gdaemondirectorymonitor.[ch]: * client/gdaemonfilemonitor.[ch]: * client/gdaemonfile.c: Add daemon directory monitor and initial work on file monitor * client/gdaemonfileenumerator.c: Make path_counter private Return DBUS_HANDLER_RESULT_HANDLED when handling messages. * client/gdaemonvfs.[ch]: Make _g_mount_ref_ref "public" * client/gvfsdaemondbus.c: Handle NULL callbacks for async calls * daemon/Makefile.am: * daemon/gvfsbackend.[ch]: * daemon/gvfsjobcreatemonitor.[ch]: Add create_dir_monitor and create_file_monitor. Add g_vfs_backend_get_daemon * daemon/gvfsmonitor.[ch]: Helper code for monitors * daemon/gvfsbackendtrash.c: Implement directory monitor for trash dirs svn path=/trunk/; revision=971
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 51a68b85..daa816f4 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -20,6 +20,7 @@ vfssources = \
gdaemonfileinputstream.c gdaemonfileinputstream.h \
gdaemonfileoutputstream.c gdaemonfileoutputstream.h \
gdaemonfileenumerator.c gdaemonfileenumerator.h \
+ gdaemondirectorymonitor.c gdaemondirectorymonitor.h \
gvfsdaemondbus.c \
$(NULL)