summaryrefslogtreecommitdiff
path: root/client/Makefile.am
diff options
context:
space:
mode:
authorAlexander Larsson <alexl@src.gnome.org>2007-09-13 13:42:03 +0000
committerAlexander Larsson <alexl@src.gnome.org>2007-09-13 13:42:03 +0000
commitcfe629c134e41e8ade484a2b8294c7a11137220b (patch)
tree39918cd966f0486e5f9252524f48935e4a4a4a5e /client/Makefile.am
parentf366fe009d8d4f66738ad541d7c8fd05ae762d4f (diff)
downloadgvfs-cfe629c134e41e8ade484a2b8294c7a11137220b.tar.gz
Move the uri parsing to modules
Original git commit by Alexander Larsson <alexl@redhat.com> at 1179152686 +0200 svn path=/trunk/; revision=564
Diffstat (limited to 'client/Makefile.am')
-rw-r--r--client/Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/client/Makefile.am b/client/Makefile.am
index 1077b786..6b4ec290 100644
--- a/client/Makefile.am
+++ b/client/Makefile.am
@@ -4,12 +4,13 @@ INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/gvfs \
-I$(top_srcdir)/common \
$(GLIB_CFLAGS) $(DBUS_CFLAGS) \
-DG_LOG_DOMAIN=\"GVFS\" -DG_DISABLE_DEPRECATED \
+ -DGVFS_MODULE_DIR=\"$(libdir)/gvfs/modules\" \
-DDBUS_API_SUBJECT_TO_CHANGE
-module_flags = -export_dynamic -avoid-version -module -no-undefined
-modulesdir = $(libdir)/gio/gvfs-modules
+giomodule_flags = -export_dynamic -avoid-version -module -no-undefined
+giomodulesdir = $(libdir)/gio/gvfs-modules
-modules_LTLIBRARIES = libgvfsdbus.la
+giomodules_LTLIBRARIES = libgvfsdbus.la
libgvfsdbus_la_LDFLAGS = $(module_flags)
libgvfsdbus_la_SOURCES = \
@@ -26,6 +27,20 @@ libgvfsdbus_la_SOURCES = \
libgvfsdbus_la_LIBADD = \
$(top_builddir)/gio/libgio.la \
- $(top_builddir)/common/libcommon.la \
+ $(top_builddir)/common/libgvfscommon.la \
$(DBUS_LIBS) \
$(GLIB_LIBS)
+
+libvfsomodule_flags = -export_dynamic -avoid-version -module -no-undefined
+libvfsmodules_LTLIBRARIES = libsmb.la
+libvfsmodulesdir = $(libdir)/gvfs/modules
+
+libsmb_la_LDFLAGS = $(module_flags)
+libsmb_la_SOURCES = \
+ smburi.c \
+ $(NULL)
+
+libsmb_la_LIBADD = \
+ $(top_builddir)/gio/libgio.la \
+ $(top_builddir)/common/libgvfscommon.la \
+ $(GLIB_LIBS)